ASCENT - Center for Technical Knowledge®
ENOVIA V5-6R2017: DMU Kinematics
1st Edition

Prepared and produced by:
ASCENT Center for Technical Knowledge
630 Peter Jefferson Parkway, Suite 175
Charlottesville, VA 22911
866-527-2368
www.ASCENTed.com

Lead Contributor: Scott Hendren

ASCENT - Center for Technical Knowledge is a division of Rand Worldwide, Inc., providing custom
developed knowledge products and services for leading engineering software applications. ASCENT is
focused on specializing in the creation of education programs that incorporate the best of classroom
learning and technology-based training offerings.

We welcome any comments you may have regarding this learning guide, or any of our products. To contact
us please email: feedback@ASCENTed.com.

© ASCENT - Center for Technical Knowledge, 2018

All rights reserved. No part of this guide may be reproduced in any form by any photographic, electronic,
mechanical or other means or used in any information storage and retrieval system without the written
permission of ASCENT, a division of Rand Worldwide, Inc.

CATIA and ENOVIA are registered trademarks of Dassault Systèmes.

All other brand names, product names, or trademarks belong to their respective holders.

General Disclaimer:
Notwithstanding any language to the contrary, nothing contained herein constitutes nor is intended to
constitute an offer, inducement, promise, or contract of any kind. The data contained herein is for
informational purposes only and is not represented to be error free. ASCENT, its agents and employees,
expressly disclaim any liability for any damages, losses or other expenses arising in connection with the use
of its materials or in connection with any failure of performance, error, omission even if ASCENT, or its
representatives, are advised of the possibility of such damages, losses or other expenses. No consequential
damages can be sought against ASCENT or Rand Worldwide, Inc. for the use of these materials by any third
parties or for any direct or indirect result of that use.

The information contained herein is intended to be of general interest to you and is provided “as is”, and it
does not address the circumstances of any particular individual or entity. Nothing herein constitutes
professional advice, nor does it constitute a comprehensive or complete statement of the issues discussed
thereto. ASCENT does not warrant that the document or information will be error free or will meet any
particular criteria of performance or quality. In particular (but without limitation) information may be rendered
inaccurate by changes made to the subject of the materials (i.e. applicable software). Rand Worldwide, Inc.
specifically disclaims any warranty, either expressed or implied, including the warranty of fitness for a
particular purpose.
Contents

Preface .................................................................................................................. v

In this Guide ....................................................................................................... vii

Practice Files .................................................................................................... ix

Chapter 1: Introduction to DMU Kinematics ....................................................... 1-1

1.1 Fundamentals ............................................................................................... 1-2

1.2 DMU Kinematics Interface .......................................................................... 1-3
    Access DMU Kinematics workbench ......................................................... 1-3
    DMU Kinematics User Interface .............................................................. 1-3

1.3 Kinematic Analysis Process ........................................................................ 1-4

1.4 Defining a Simulation ................................................................................ 1-5
    Modifying a Joint ................................................................................. 1-10
    Deleting a Joint ................................................................................ 1-10
    Degrees of Freedom ........................................................................... 1-12

1.5 Mechanism Analysis ................................................................................... 1-13

1.6 Simulating with Commands ........................................................................ 1-14

Practice 1a Create a Mechanism ....................................................................... 1-15

Chapter 2: Constraint-Based Joints .................................................................. 2-1

2.1 Constraint-Based Joints ............................................................................. 2-2

2.2 Prismatic Joint ............................................................................................ 2-3

2.3 Cylindrical Joint ........................................................................................ 2-5

2.4 Screw Joint .................................................................................................. 2-7

2.5 Spherical Joint ............................................................................................ 2-9

2.6 Planar Joint .................................................................................................. 2-10

2.7 Rigid Joint ................................................................................................... 2-11

Practice 2a Create a Prismatic Mechanism ....................................................... 2-12
Practice 2b Create a Cylindrical Mechanism ........................................... 2-15
Practice 2c Create a Screw Mechanism .................................................. 2-18
Practice 2d (Optional) Create a Slide Block Mechanism ...................... 2-21

Chapter 3: Curve/Surface-Based Joints..................................................... 3-1
3.1 Point Curve Joint ............................................................................. 3-2
3.2 Slide Curve Joint ............................................................................ 3-3
3.3 Roll Curve Joint ............................................................................. 3-4
3.4 Point Surface Joint ......................................................................... 3-5
Practice 3a Slot Follower Mechanism ................................................... 3-6
Practice 3b Create a Cam Mechanism ................................................... 3-11
Practice 3c Roll Curve Joint .................................................................. 3-15

Chapter 4: Ratio-Based Joints ................................................................. 4-1
4.1 Ratio-Based Joints .......................................................................... 4-2
4.2 Universal Joint ................................................................................ 4-3
4.3 Gear Joint ........................................................................................ 4-5
4.4 Cable Joint ..................................................................................... 4-7
4.5 Rack Joint ....................................................................................... 4-9
4.6 Constant Velocity Joint .................................................................. 4-11
4.7 Axis-based Joint ............................................................................. 4-12
Practice 4a Universal Joint Mechanism................................................. 4-14
Practice 4b Gear Joint Mechanism ....................................................... 4-17
Practice 4c Cable Joint Mechanism ....................................................... 4-21
Practice 4d Rack Joint Mechanism ....................................................... 4-23
Practice 4e Create a CV Joint Mechanism ........................................... 4-26

Chapter 5: Simulations............................................................................. 5-1
5.1 Simulating the Mechanism ............................................................... 5-2
5.2 Compiling a Simulation .................................................................. 5-5
  Replay ............................................................................................... 5-5
  Animation File .................................................................................. 5-6
5.3 Replaying a Simulation ................................................................... 5-9
Practice 5a Simulate a Mechanism ....................................................... 5-10
Practice 5b Simulating the Cam Mechanism ....................................... 5-17
Chapter 6: Analysis Results .............................................................. 6-1
  6.1 Swept Volumes ........................................................................... 6-2
  6.2 Traces .......................................................................................... 6-5
  6.3 Sensors ........................................................................................ 6-7
    General Steps .................................................................................. 6-8
    Graphical Output ............................................................................. 6-10
    File Output ..................................................................................... 6-11
    Instantaneous Values Tab .............................................................. 6-11
    History Tab ..................................................................................... 6-12
  6.4 Clash ............................................................................................ 6-13
    Automatic Clash Detection .............................................................. 6-13
    Clash Tool ....................................................................................... 6-14
Practice 6a Analysis Results .............................................................. 6-17
Practice 6b Clash Analysis .............................................................. 6-24

Chapter 7: Data Reuse ................................................................................. 7-1
  7.1 Assembly Constraint Conversion ................................................. 7-2
  7.2 CATIA V4 Mechanisms ................................................................ 7-7
Practice 7a Converting Assembly Constraints I ........................................... 7-10
Practice 7b Convert Assembly Constraints II ........................................... 7-13
Practice 7c (Optional) Converting V4 Assemblies .................................... 7-19

Chapter 8: Laws in ENOVIA DMU .............................................................. 8-1
  8.1 Simulation with Laws in ENOVIA DMU ......................................... 8-2
  8.2 Using 2D Curves ........................................................................... 8-6
    Sketch ............................................................................................... 8-6
    Text File ........................................................................................... 8-7
    Sketch ............................................................................................... 8-8
    Text File .......................................................................................... 8-10
    Editing the Command ...................................................................... 8-11
Practice 8a Laws - ENOVIA DMU ........................................................... 8-13
Practice 8b Using 2D Curves .............................................................. 8-19
Preface

The ENOVIA V5-6R2017: DMU Kinematics learning guide focuses on how to create and simulate V5 mechanisms using CATIA products. The course begins with an overview of the mechanism design process and then each step in the process is discussed in depth using lectures and hands-on practices. This course also introduces the concept of converting assembly constraints into kinematic joints. Additionally, this learning guide provides an introduction to converting V4 mechanisms to V5 as well as the 3D model method of creating kinematic assemblies.

Topics Covered:

• Kinematic analysis process
• Constraint-based joints
• Curve/surface-based joints
• Ratio-based joints
• Compiling and replaying a simulation
• Swept volumes
• Traces
• Sensors
• Clash detection
• Assembly constraint conversion
• CATIA V4 mechanisms
• Simulation with laws
Note on Software Setup

This learning guide assumes a standard installation of the software using the default preferences during installation. Lectures and practices use the standard software templates and default options for the Content Libraries.

This content was developed against CATIA V5-6R2017, Service Pack 1.

Lead Contributor: Scott Hendren

Scott Hendren has been a trainer and curriculum developer in the PLM industry for over 20 years, with experience on multiple CAD systems, including Pro/ENGINEER, Creo Parametric, and CATIA. Trained in Instructional Design, Scott uses his skills to develop instructor-led and web-based training products.

Scott has held training and development positions with several high profile PLM companies, and has been with the Ascent team since 2013.

Scott holds a Bachelor of Mechanical Engineering Degree as well as a Bachelor of Science in Mathematics from Dalhousie University, Nova Scotia, Canada.

Scott Hendren has been the Lead Contributor for ENOVIA: DMU Kinematics since 2013.
In this Guide

The following images highlight some of the features that can be found in this guide.

Practice Files

The Practice Files page tells you how to download and install the practice files that are provided with this guide.

Link to the practice files

Chapters

Each chapter begins with a brief introduction and a list of the chapter’s Learning Objectives.

Learning Objectives for the chapter

Getting Started

In this chapter you learn how to start the AutoCAD® software, become familiar with the basic layout of the AutoCAD screen, how to access commands, use your pointing device, and understand the AutoCAD Cartesian workspace. You also learn how to open an existing drawing, view a drawing by zooming and panning, and save your work in the AutoCAD software.

Learning Objectives in this Chapter

- Launch the AutoCAD software and complete a basic setup of the drawing and menu bar.
- Identify the basic layout and features of AutoCAD software including the Ribbon, Drawing Window, and Application Menu.
- Locate commands and launch them using the Ribbon, shortcut menus, Application Menu, and keyboard.
- Locate points in the AutoCAD Cartesian workspace.
- Open and save existing drawings and manage them to other locations.
- Move around a drawing using the mouse, the Zoom and Pan commands, and the Navigator bar.
- Save drawings in various formats and set the automatic save options using the Save options.
Side notes
Side notes are hints or additional information for the current topic.

Practice Objectives

Practices
Practices enable you to use the software to perform a hands-on review of a topic.

Some practices require you to use prepared practice files, which can be downloaded from the link found on the Practice Files page.
Chapter 1

Introduction to DMU Kinematics

The DMU Kinematics workbench is used to analyze the kinematic motion of an assembly model developed in CATIA V5. Real world motion is simulated by applying joints and commands to a model. Simulations are run by modifying the command through a range of values to drive the motion of the assembly. Here, you are introduced to the process of creating and simulating a mechanism in DMU Kinematics.

Learning Objectives in this Chapter

- Understand the fundamentals of the DMU Kinematics workbench.
- Review the DMU Kinematics interface.
- Understand the Kinematic Analysis process.
- Define a Simulation.
- Run a mechanism analysis.
- Use the Simulation with Commands tool to modify the value of the commanded joint.
1.1 Fundamentals

The CATIA V5 DMU Kinematics workbench assists in the design and analysis of mechanisms. DMU Kinematics enables you to create a virtual mechanism that answers the following questions about a product’s design (the mechanism shown in Figure 1–1 is described in these examples):

1. **Clash Detection**: Are the components of the mechanism going to collide? For example, is the handle going to collide with the base model during operation?

2. **Motion**: Are the components in the mechanism going to move according to the design intent? For example, is there going to be any rotational motion in the pin? Is the system going to lock up at any point throughout the range of motion of the handle?

3. **Velocity and Acceleration**: How fast is the mechanism going to move? Given a specified input rotational velocity at the handle, what be the corresponding linear velocity of the pin going to be?

The information obtained from a kinematic analysis can provide better design alternatives for your mechanism.
1.2 DMU Kinematics Interface

To use the kinematic motion analysis functionality in ENOVIA or CATIA, you must access the DMU Kinematics workbench. This is done by selecting Start>Digital Mockup>DMU Kinematics.

The workbench symbol changes to .

The interface for the DMU Kinematics workbench is similar to the other DMU interfaces. The primary differences are the toolbar options that change to Kinematic specific tools, as shown in Figure 1–2.
1.3 Kinematic Analysis Process

Analyzing a model using DMU Kinematics consists of five main steps:

1. Define a simulation.
2. Perform a mechanism analysis.
3. Run the simulation to test joints and commands.
4. Create a simulation replay.
5. Define outputs.

Each of these steps are described in detail throughout the learning guide.
1.4 Defining a Simulation

A simulation consists of the following components:

- **Kinematic Mechanism**: Consists of parts in an assembly. The joints connect each part of the assembly.
- **Fixed Part**: A part that remains stationary while all other parts move in relation to it.
- **Joint**: Defines the type of movement permitted between two or more parts. DMU Kinematics contains seventeen types of joints.
- **Command**: When a joint is commanded, it can be driven by length and/or angle values. As the values change, the joint moves.

Use the following general steps to define a simulation:

1. Create a new mechanism.
2. Define a fixed part.
3. Create joint(s).
4. Define a command.

### General Steps

The first step in defining a simulation is to create a new mechanism. It acts as a storage location for all of the objects of the mechanism in the specification tree. Joints, commands, the fixed part, and anything else related to the mechanism can be found by expanding Applications and Mechanisms in the specification tree, as shown in Figure 1–3.

To create a mechanism, select **Insert>New Mechanism**. The system automatically adds a **Mechanism.1, DOF = 0** entry to the specification tree.
A mechanism must exist before any other Kinematic entities can be created. You can also create a new mechanism while defining the fixed part (or a joint) by clicking **New Mechanism**, as shown in Figure 1–4.

![New Mechanism dialog box](image)

**Figure 1–4**

It is only necessary to create a single mechanism. Multiple mechanisms can be created to contain a variety of different kinematic setups and analyses. However, a simulation can only run one mechanism at a time.

### Step 2 - Define a fixed part.

To put a mechanism into motion, you must define a ground or fixed part to remain stationary while all other parts move in relation to it.

To define a fixed part, click ![Fixed Part](image) (Fixed Part) in the DMU Kinematics toolbar. The New Fixed Part dialog box opens as shown in Figure 1–5, indicating the mechanism in which the fixed part is going to be defined.

![New Fixed Part dialog box](image)

**Figure 1–5**

To continue the definition, select the part that is going to be anchored. It displays a small anchor symbol and the specification tree displays the part name under the **Fix Part** branch, as shown in Figure 1–6.
Only one fixed part can be defined for a mechanism. If more than one part represents the ground in a mechanism, one of the following operations must be performed:

- Deactivate all other parts that are not going to be in motion.
- Copy all PartBody geometry into one part and remove the source parts from the assembly.
- Create **Rigid** joints between the fixed part and all of the other parts that are not in motion.

### Step 3 - Create joint(s).

Other than the fixed part, all of the other parts in the assembly model are free to move anywhere in the reference frame. The reference frame consists of six degrees of freedom: rotation and translation along the X-, Y-, or Z-axes as shown in Figure 1–7.

A joint connects two parts and indicates how one part moves in relation to another. Consequently, a joint constrains the relative motion or the degrees of freedom of the two parts.
For example, a **Revolute** joint can be used to define rotational motion, such as a wheel rotating about an axle, as shown in Figure 1–8. Once the joint has been defined, the wheel is only free to rotate about the axis of the axle and is said to have one degree of freedom.

To create a **Revolute** joint, click 📐 (Revolute Joint) in the Kinematic Joints toolbar. The Joint Creation: Revolute dialog box opens as shown in Figure 1–9.

You must select each line and plane in the correct order; read the prompts.

Select the required geometry in the correct order. Look for the prompts in the lower left corner of the window. Defining a Revolute joint requires that you select a line and a plane from each model.
The two lines define the axis of rotation. Since no translational degree of freedom is permitted along the axis of rotation, the planes define the relative position of the two models. The planes must be perpendicular to the selected lines. Three options can be used to define the planes:

- **Null Offset**: The planes are coincident.
- **Offset**: The planes are parallel and at a user-defined distance. This distance defaults to the assembled distance.
- **Centered**: Four planes must be selected. Planes 1 and 3 have to be centered between planes 2 and 4, as shown in Figure 1–10.

![Figure 1–10](image)

Click **OK** to create the joint. The system updates the positions of the two parts according to the selections made for the Revolute Joint. If the model positions do not update, you can do so manually by clicking (Update Positions).

When working in DMU Kinematics in the CATIA interface, you can force the system to automatically update the assembly constraints by selecting **Tools>Options>Mechanical Design>Assembly Design>General** tab and selecting **Automatic**, as shown in Figure 1–11. This option is not available in the ENOVIA interface.

![Figure 1–11](image)
Modifying a Joint

To modify a joint, locate it in the specification tree and double-click on its name, as shown in Figure 1–12.

The Joint Creation dialog box used to create the joint opens. You can modify any aspect of the joint properties, except the geometry used to define the joint. If the geometry changes, the joint must be deleted and a new joint defined in its place.

Deleting a Joint

To delete a joint, right-click on the joint in the specification tree and select Delete. You can click More in the Delete dialog box to display additional information, as shown in Figure 1–13.
Constraint based joints, such as the **Revolute** joint, create assembly constraints. A parent/child relationship exists between the joint and the constraints. The children of the joint are listed in the expanded version of the Delete dialog box. Select any children that should be deleted with the joint and click **OK**.

### Step 4 - Define a command.

A command is used to drive the motion of the mechanism by specifying the angle or length values for a joint. At least one joint in a mechanism must be commanded. A joint that is commanded can have its value modified causing the mechanism to move.

To define a command, select **Angle Driven** or **Length Driven** in the Joint Creation dialog box. Depending on the unconstrained degrees of freedom for a joint, you can select angle, length, or both. For example, a **Revolute** joint enables rotation and can only be angle-driven, as shown in Figure 1–14.

![Figure 1–14](image)

Once the mechanism has been completely defined, the Information dialog box opens as shown in Figure 1–15. The mechanism can now be placed in motion.

![Figure 1–15](image)
Degrees of Freedom

The degrees of freedom of the mechanism must equal zero for it to be simulated by DMU Kinematics. The degrees of freedom can be obtained from the specification tree, as shown in Figure 1–16.

If the number of degrees of freedom is greater than zero, verify the following settings:

- Has at least one command been defined?
- Has a fixed part been defined?
- Have enough joints been defined to simulate the mechanism according to the design intent?

Figure 1–16

Degrees of freedom equal 0
1.5 Mechanism Analysis

The Mechanism Analysis is used to confirm that the model is ready to be simulated in DMU Kinematics. To perform a mechanism analysis, click (Mechanism Analysis) or select Analyze>Mechanism Analysis. The Mechanism Analysis dialog box opens as shown in Figure 1–17.

The following questions should be answered using the Mechanism Analysis dialog box:

- Are the degrees of freedom with commands equal to 0?
- What are the number of commands?
- What are the number of joints?
- Is a fixed part defined?
- Can the mechanism be simulated?
1.6 Simulating with Commands

The **Simulation with Commands** tool enables you to modify the value of the commanded joint. As DMU Kinematics plays through these values, the mechanism is placed in motion.

To run a simulation with commands, click (Simulation with Commands). The Kinematics Simulation dialog box opens as shown in Figure 1–18. If the dialog box does not display exactly as shown in Figure 1–18, click More.

![Figure 1-18](image)

The current value of the command is shown next to the command name. This indicates the start point for the animation. The end value can be specified by using the slider bar or by entering a new value.

The simulation can be run using the following methods:

- **Immediate**: The mechanism immediately repositions itself to the new command value when it is entered.

- **On request**: The mechanism animates between the current and new command values by clicking . The speed of the animation is controlled by the *Number of steps* value. A large value creates more steps between the start and end values and produce a slower animation.

Click **Reset** to return the mechanism to its original position.
Practice 1a  Create a Mechanism

Practice Objectives

- Create a mechanism.
- Create a fixed part.
- Create a Revolute joint.
- Simulate the mechanism.

In this practice, you will create a simple kinematic mechanism using the wheel assembly shown in Figure 1–19.

Figure 1–19

The shaft model is defined as the fixed part. A commanded Revolute joint will be defined between the shaft and the rim to simulate rotational motion. Once the mechanism has been prepared, it will be simulated.

Task 1 - Open Wheel.CATProduct.

1. Open the assembly model Wheel.CATProduct. To quickly locate the assembly, you can expand the Type drop-down list and select Products (*.CATProduct).
The assembly consists of a rim part and a shaft part that have been snapped together. The assembly displays as shown in Figure 1–20.

**Figure 1–20**

2. Verify that you are in the DMU Kinematics workbench. The workbench symbol should be . If not, select Start> Digital Mockup> DMU Kinematics.

**Task 2 - Create a new mechanism.**

1. Select Insert> New Mechanism to build the mechanism structure. A Mechanism entry displays under the Applications branch in the specification tree.

2. Expand the Mechanisms branch in the specification tree to display the structure, as shown in Figure 1–21.

**Figure 1–21**
Task 3 - Define the fixed part.

1. Click (Fixed Part). The New Fixed Part dialog box opens as shown in Figure 1–22.

![Figure 1–22](image)

2. Select Shaft in the window or specification tree. An anchor symbol displays on the part as shown in Figure 1–23. You might need to zoom in on the part to display the anchor symbol.

![Figure 1–23](image)

Task 4 - Define a Revolute joint.

1. Use the compass to move the two models apart. Since the model is in its assembled position, this will make it easier to select references for the joint. The assembly displays, as shown in the example in Figure 1–24.

![Figure 1–24](image)
2. Click \(\text{Revolute Joint}\). The Joint Creation: Revolute dialog box opens as shown in Figure 1–25.

![Joint Creation: Revolute dialog box](image)

3. Make the following selections using Figure 1–26 as a guide:

- **Line 1**: Select the axis of Shaft.
- **Line 2**: Select the center axis of WheelRim.
- **Plane 1**: Select the end of the Shaft.
- **Plane 2**: Select the center planar surface of WheelRim.
- **Offset**: Select this option and enter -8mm.

![Figure 1–26](image)

4. Click **OK** to complete the joint definition.
5. The shaft model should automatically update to the position defined by the joint, as shown in Figure 1–27. If the model does not automatically update, click and OK.

![Figure 1–27](image)

**Figure 1–27**

**Task 5 - Define a command.**

This mechanism only has one joint. Redefine the Revolute joint by adding an angle-driven command.

1. Expand the specification tree to display the Revolute.1 joint, as shown in Figure 1–28.

![Figure 1–28](image)

**Figure 1–28**

2. Double-click on Revolute.1 to open the Joint Definition dialog box. Note that the Joint geometry area is not available. You cannot redefine the geometry used to define a joint.
3. Select **Angle driven** and click **OK**. An Information window opens, as shown in Figure 1–29.

![Information Window](image)

**Figure 1–29**

4. Note that the specification tree indicates that the degree of freedom for **Mechanism.1** is 0. It is now possible to simulate the mechanism. Click **OK**.

**Task 6 - Analyze the mechanism.**

1. Select **Analyze>Mechanism Analysis**. The Mechanism Analysis dialog box opens as shown in Figure 1–30.

![Mechanism Analysis Dialog Box](image)

**Figure 1–30**

2. The Mechanism Analysis is useful for de-bugging problems with a mechanism. In this dialog box, confirm the following information:
   - **Mechanism can be simulated**: *Yes*
   - **Number of joints**: 1
3. Click Close.

**Task 7 - Simulate the mechanism.**

In this task, you will use the Simulation with Commands tool to animate the mechanism. This enables you to modify the value of the command-driven Revolute.1 joint so that the rim will rotate about the shaft.

1. Click (Simulation with Commands). The Kinematics Simulation dialog box opens as shown in Figure 1–31. If the dialog box opens differently, click **More**.

![Figure 1–31](image)

2. Move the dialog box so that the model displays and verify that the Immediate option in the Simulation field is selected.

3. Slowly drag the Command.1 slider to -360. As you drag the slider, pause momentarily and watch as the model updates with the new command value.

4. Select **On request**. For Number of steps, enter 80.

5. Modify the Command value to 360.

6. Click . The model will animate through two complete revolutions (or 720 degrees).

7. Click Close.

8. Save the assembly and close the window.